OpenFOAM fails to build on ppc64le

Description

Although it was enabled for PPC64LE, OpenFOAM does not build flawlessly on ppc64le. I am aware that these errors are due to lack of linking when building, but I cannot find the way to add those libs in the build system. I followed the procedures of http://www.openfoam.org/download/git.php PS: I am not sure how important this is, but I also had to install libptscotch-dev

Steps To Reproduce

On a ppc64le machine, after all set: cd $WM_PROJECT_DIR ./Allwmake

Additional Information

I am attaching the second time I ran the script, because it shows mainly the errors and I ran it without parallel jobs.