autoload loop error for lists/must_be/2